Forum Index > Projects > LED Pegboard and Matrix Projects
 meggy jr -- columns C2 and C6 will not light
 |  Printable Version
By: Anonymous: zenkat () on Sunday, May 31 2009 @ 11:28 AM PDT (Read 4215 times)  
Anonymous: zenkat

Hi!

I put together my Meggy JR last night, and I have it "almost" working ...

On power-up, the screen cycles through its color / boot-up pattern -- except none of the LEDs in columns 2 or 6 light up (counting from 0 from the left, under single white LEDs D2 and D6).

The default game then starts. Game play is normal, except that again, no LEDs in columns 2 or 6 light up. The attacking tomatoes disappear when moving through these columns, and then (obviously) reappear on the other side. My shots do not light up these columns, and the game over "explosion" does not light these columns up either. Etc Etc Etc.

In other words, everything on the board appears to be working -- except for columns 2 and 6 of the LED display.

I went and checked all of the solder joints on the back of the board, and touched up a few of the points that looked like they may have been substandard. No difference.

Upon initial installation, I had some problems with clearance with capacitor C3, which I fixed by pulling out and reseating the LED matrix. However, I don't think this is still part of the issue -- I've done some continuity checks from the solder joints on the back of the board to the pins of the LED matrix in the ULH corner near the capacitor, and everything looks OK.

Anyways, I'm a rookie at projects like this, and feeling a bit stuck. Can anyone provide any advice on how to go about debugging this problem? Are there any components whose failure / improper installation would cause a whole column to fail to light?

Thanks a bunch in advance!






       
   
By: Anonymous: zenkat () on Sunday, May 31 2009 @ 12:43 PM PDT  
Anonymous: zenkat


OK, this is weird ... while playing with my meggy, I noticed that column 6 would occasionally light up, only to go out again after 2-15 secs.

Not flickering -- just working normally for a while, then disappearing again. Happened several times while playing it. Did not seem to be associated with anything mechanical (jiggling, positioning, etc) -- just random.

Column 2 remained unlit the entire time, however.






       
   
By: Windell (offline) on Sunday, May 31 2009 @ 11:57 PM PDT  
Windell

This sounds like a soldering issue. Fortunately (1) you've given a clear description of the problem and (2) have a continuity checker, so we have a good starting point-- we should be able to get you back to working in no time.

Column 2 is controlled by Pin 13 of the microcontroller, which goes through RB5 to one of the pins of Q5. Q5 then leads to pin 9 of the LED display. Pin number, for both the microcontroller and LED display, starts with the *square* pad at one corner-- which is pin number 1 (not zero), and proceeds around clockwise when looking at the BOTTOM of the circuit board.

Column 6 is controlled by pin 5 of the microcontroller, which goes to one end of RB1, and then from the other end of RB1 to one of the pins of Q1. After the transistor, the signal goes to pin 25 of the LED display.

So, check those paths with the continuity tester. Hopefully you'll be able to find a flaky but fixable solder joint in each of those two paths. If you do have continued difficulty, please let us know and we'll try to come up with some additional suggestions.


Windell H. Oskay
drwho(at)evilmadscientist.com
http://www.evilmadscientist.com/

Forum Evil Scientist
Evil Scientist

Status: offline

Registered: 06/15/06
Posts: 1932
Sunnyvale, CA

Profile Email Website  
   
By: Anonymous: zenkat () on Monday, June 01 2009 @ 08:24 AM PDT  
Anonymous: zenkat

Wendell --

Thanks for the prompt & clear reply!

I think I see the problem now. I have an open circuit between pin 13 of the microcontroller and R5. To be clear, I count pin 13 as being the one below C8 (centered between the two pins of C8, actually) and I'm testing the outer lead of R5 (the one adjacent to switch b3).

I can confirm that pin 12 to R4 is a connected, and pin 14 (the corner pin) to R6 is connected, but 13-R5 is definitely open.

The thing is, both solder joints look clean. In fact, I'm having trouble seeing how this could be a soldering problem, since my continuity test is only checking the circuit board connection between the two locations. I've probed all around each of the joints, and I can find no trace of a connection.

Could a bad solder joint somehow be obscuring access to the connection? Or could have I damaged the circuit board connect with my soldering iron somewhere along the path?

Final data points before I go to work: I can see some finite resistance between pin 13 and R4 / R6, but not between pin 12 / pin 14 and R5, which leads me to believe that the problem lies in the R5 joint. I tried touching this joint up, but still no trace of a connection.

Advice on where to go next? Run a patch wire from pin 13 to R5?

Thanks again for all your help!






       
   
By: Anonymous: zenkat () on Monday, June 01 2009 @ 08:36 AM PDT  
Anonymous: zenkat

Windell --

One other question, if you have a spare moment to educate a rookie about circuit design ...

Looking at the schematic, I can trace pin 13 [labeled "PD7 (AIN1)"] to RB5, through Q5, and to pin 9 of the BL-M23 controller. However, this pin is labeled "Row6".

How does this end up controlling column 2?

Thanks!
Brian






       
   
By: Windell (offline) on Monday, June 01 2009 @ 10:31 AM PDT  
Windell

If you can't manage to get things to cooperate by touching up the solder joints, *and* the problem is an open circuit (i.e., no connection) between two points, you can always patch it with a wire. Not really the best solution, but it will work.

(Our boards are electrically tested and packed carefully, so there should not be any broken traces on the board when you get it, but the traces and vias can sometimes break if you get them too hot. Try to solder quickly-- *never* more than 2-3 seconds at any one location.)

If you have a "finite" resistance, that's a bit ambiguous. If it's near zero, that's good. If it's large but finite, that probably means something funny is going on. If you've got connections that should *not* be there, then you've probably added a connection you didn't mean to-- check for solder bridges, or metallic dust.

The pin names are a bit confusing. There are two sources for this.

First, there is the good old conflict between numbering starting at zero (like we use for data) versus starting at 1 (like we use for physical objects). The pin numbers, and LED numbers inside the LED matrix display start at 1, but our data lines are numbered starting at 0. That's how bit 5 of our control circuit ends up going to "Row 6" of the matrix. (Ugh.)

The second thing to note is that the display pins are labeled with respect to the *label* on the display, which points to the left on Meggy Jr RGB. To put yourself in the right frame of reference for the display, turn Meggy Jr sideways, (buttons facing away from you) such that you can read the label. Then, the top row is "Row 1", and "Row 6" is the stripe to the right of D2. These designations, the pinout, and the row and column numbers, can be found in the datasheet for the LED matrix display, which is linked from the Meggy Jr RGB product page.


Windell H. Oskay
drwho(at)evilmadscientist.com
http://www.evilmadscientist.com/

Forum Evil Scientist
Evil Scientist

Status: offline

Registered: 06/15/06
Posts: 1932
Sunnyvale, CA

Profile Email Website  
   
By: Anonymous: zenkat () on Monday, June 01 2009 @ 07:17 PM PDT  
Anonymous: zenkat

Hi Windell --

The pin13-to-RB5 connection is a full open (infinite resistance).

I wouldn't be surprised if I scorched the board at one point. I think I may have been using too big/hot of an iron in the first place, anyways.

I'll try the patch wire, see how it works. More later.

Thanks!
Brian






       
   
By: Anonymous: zenkat () on Monday, June 01 2009 @ 10:25 PM PDT  
Anonymous: zenkat


Meggy jr FTW!

Put the patch wire in from pin 13 to R5. Works like a charm, even if it looks a bit ugly. (Actually, I think it might even help with the DIY aesthetic!)

Now, on to programming something! Maybe a paint app?

Thanks for all the help, Windell. Much appreciated!

PS -- I'm pretty sure one of two things happened here. Either I cooked the trace (which is very possible, the back of my PCB has light brown stains from my iron), or I clipped the connection to the socket when I got overenthusiastic with the diagonal cutters. Guess that's why they call it a "learning exercise"!






       
   
By: karlgg (offline) on Saturday, June 06 2009 @ 11:11 PM PDT  
karlgg

Being a white PCB, the brown stains might just be the flux from the solder (or at least in part). If you can't gently scrub it off with a q-tip and some alcohol, it's more likely a burn. Razz

And even with an "appropriate" (or even under-sized) iron, you can still burn things up... One of the things to learn as you're soldering is when enough is enough. Having a functioning Meggy Jr means you're not too far from it - ICs are generally the more delicate parts, and you've managed to get past those okay. Smile


I think I am, therefore I am... I think
Forum Mad Scientist
Mad Scientist

Status: offline

Registered: 01/25/09
Posts: 81

Profile Email    
   



 All times are PDT. The time is now 02:39 AM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Able to Post 
Filtered HTML Allowed 
Censored Content 

Evil Mad Scientist Forum Archives — Read only!

Please visit our new forums for new discussions.


DIY Hardware for Electronic Art


The Original Egg-Bot Kit


Octolively
Interactive LED kits


Meggy Jr RGB
LED matrix game
development kit.


Business-card sized
AVR target boards


Peggy 2
LED Pegboard kits

My Account






Lost your password?