Forum Index > Projects > Egg-Bot
 Unable to find an eggbot on any serial port. :(
 |  Printable Version
By: Anonymous: MrDude_1 () on Tuesday, November 22 2011 @ 04:46 PM PST (Read 4652 times)  
Anonymous: MrDude_1

Hello,
I have a bit of a problem.

I have assembled my eggbot, but I seem to have a communications issue.
Heres what i have done:

all computers are windows XP pro, SP3

Installed inkscape .48
i ran inkscape at the end of the install to confirm it worked.
using installer package, i installed the eggbot extensions.
using installer package, i installed the eggbot driver exe to its default location under inkscape.
I browsed to the default driver, and ran the exe.
in the driver install window, i clicked the install driver button.
the FIRST TIME i plug in the eggbot, lights flash, the found new hardware screen came up. it found it as a USB serial device of some kind. everything seemed fine.
I opened inkscape
went to the eggbot extension.
went to the setup tab.
clicked apply to toggle the pen.
the pen lift servo moved.
i clicked apply again..
then i get the "Unable to find an eggbot on any serial port. Frown" message.
I continue to get this message even when i reboot. unplug, reset. unplugging both the external power and the USB, hitting the reset button, etc. its like its dead.

i then spend the rest of the night in frustration trying to figure it out. im worried its fried.
I have a old netbook thats not really approprate for plotting (low memory, and SLOW SSD) but i spend an hour installing inkscape...(its slow)
i go through the same process above.
and.... the servo moved... happy, i went to bed.

so im thinking the other laptop i had is junk... so the next day i borrow another PC from work. while at work i install everything i need on it, using the listed procedure above.
same result.
upon first plug in, it appears to install, and then works for ONE command. then i cant find it.

note, i cant seem to find it in the device manager(the windows control panel one) either. should it be in there?
because i cant find it in there, i am not sure how to uninstall it, if that matters.
also, i never see the USB light flash, ever.
when i leave it plugged in sometimes the servos twitch for a second.. i cant see them, but i hear them.

i have tried bringing up HyperTerminal, so i can send a V command, however I dont see it listed in the ports.

im fairly sure that the problem is some kind of driver related installation issue.. but i dont know how to resolve it, as i cant find how it thinks its installed.... so i cant undo it... and that keeps it from re-installing.
i dont THINK its the board, since it did find itself on 3 seperate computers... but it may be the board.

im frustrated, and out of ideas.
worse part is, i shouldnt be. I write windows software for a living, and as a hobby i do pic microcontroller stuff.... lol. this should have been easy for me LOL





       
   
By: Anonymous: MrDude_1 () on Tuesday, November 22 2011 @ 04:48 PM PST  
Anonymous: MrDude_1

also, I have installed inkscape .47 final, put the extension on it... same result.





       
   
By: Anonymous: MrDude_1 () on Tuesday, November 22 2011 @ 05:06 PM PST  
Anonymous: MrDude_1

so i found a neat tool that lets me see all installed USB devices: http://www.nirsoft.net/utils/usb_devices_view.html

the eggbot was listed in there.
using the tool i uninstalled the eggbot, and some of my old usb drives.
i noticed something. whenever i plugged in any USB device, or unplugged it, the system plays a noise.
with the eggbot, no noise. plugging in or unplugging. no USB light on the board flashing, ever.





       
   
By: Anonymous: EmbeddedMan () on Wednesday, November 23 2011 @ 10:16 AM PST  
Anonymous: EmbeddedMan

MrDude,

So I don't have an answer for you, but I believe you are correct that there is a driver related problem going on. If you don't here the "you just plugged in a USB device" sound from Windows, that means that Windows tried to enumerate the USB device and never got to the end of that process properly.

Now, with your really slow laptop, does the EggBot get recognized every time you plug it in and try to send commands? (I.e. we can rule out a problem with the EggBot itself)

There must be some commonality between the two machines that it is failing on. Have you tried using a hub in between the PC and the EggBot? Maybe that would make a difference.

And yes, once it has enumerated properly it will show up in the Device Manager under LPT and COM ports.

But you're not getting that far for some reason.

*Brian





       
   
By: Anonymous: MrDude_1 () on Monday, November 28 2011 @ 07:53 AM PST  
Anonymous: MrDude_1

well, I just remembered I posted this, so I should update it.

after much working out, i figured out what it is.
if i moved the USB connector just right it works. but the vibration of the moving eggbot will disconnect it.
everytime i plugged in a new laptop it was to my right with the eggbot in-front of me. this put the cord slack (no tension, not tight or anything) to the proper direction to make it work.

i eventually figured this out by putting the eggbot on end, with the board up in the air. if i put the plastic handle of my screwdriver on the USB connector, it worked.... until the vibration of it moving made it disconnect.

I called support and bought another board. it should be here to day, and i can get to plotting.. im behind on my christmas ornaments. lol.





       
   
By: Anonymous: Carl () on Sunday, January 01 2012 @ 07:09 PM PST  
Anonymous: Carl

Unable to find an Eggbot on any serial port. Is the message I get when I try to put the egg bot on the lap top 64 bit computer running windows. the lights work and the egg bot works on my desk top. I am sure it is something in a setting but I have tried every single link over and over again. Does anyone have any suggestions?





       
   
By: Windell (offline) on Monday, January 02 2012 @ 03:26 PM PST  
Windell

Check to make sure that the Eggbot driver for Windows is installed correctly; this is a separate piece of software from the Eggbot extensions for Inkscape.


Windell H. Oskay
drwho(at)evilmadscientist.com
http://www.evilmadscientist.com/

Forum Evil Scientist
Evil Scientist

Status: offline

Registered: 06/15/06
Posts: 1932
Sunnyvale, CA

Profile Email Website  
   
By: Anonymous: esjayel () on Saturday, March 31 2012 @ 09:32 AM PDT  
Anonymous: esjayel

Getting the same error on a mac, not sure how to start troubleshooting.

Inkscape 0.48.2 r9819
Eggbot Drivers: 2.2.2r2 (automatic install)
Mac OSX 10.7.3

I see the Eggbot Control panel, but choosing > Manual > Check EBB Version doesn't find any serial devices.

3.3V LED on the EIBot board is lit, and the USB led is flashing at about 1 Hz.

Suggestions? Thanks. MMQVDO





       
   
By: dnewman (offline) on Saturday, March 31 2012 @ 09:49 AM PDT  
dnewman

FWIW, I'm running across more and more Mac apps which behave poorly and will grab control of USB devices they think smell like their USB device. That's poor behavior as USB has nice mechanisms to identify whether a device is "yours" or not. For example, the Mac software for the popular Livescribe pen will grab the Eggbot USB device, try to write data to it, get frustrated, but nonetheless hang on to the device making it unavailable to other applications. And, it does that in the background as soon as you plug in the Eggbot.

The only way I know to analyze that is either by looking at the console logs or using a tool like lsof to see which processes have grabbed control of a device.

Mind you, the problem might be something different entirely. I mention as I'm seeing this come up
more often.

Dan


Cow Canyon Saddle Clear Sky Chart


Forum Evil Scientist
Evil Scientist

Status: offline

Registered: 09/08/10
Posts: 149
Mt. Baldy,
California

Profile Email    
   
By: Windell (offline) on Saturday, March 31 2012 @ 10:00 PM PDT  
Windell

esjayel,
Do you have any USB devices connected to your computer, or USB devices that use special drivers that are or are not connected to your computer, which could potentially be interfering with the communication?


Windell H. Oskay
drwho(at)evilmadscientist.com
http://www.evilmadscientist.com/

Forum Evil Scientist
Evil Scientist

Status: offline

Registered: 06/15/06
Posts: 1932
Sunnyvale, CA

Profile Email Website  
   
By: Anonymous: esjayel () on Sunday, April 01 2012 @ 03:33 PM PDT  
Anonymous: esjayel

Nothing special so far as I know. I tried looking at the system logs, but couldn't make sense of it.

The computer (imac) did have Wacom Bamboo drivers on it - I uninstalled them but still couldn't get the mac to recognize the EiBot board.

Today I switched over to a (nearly) fresh Mac Air with nothing attached to it, and still getting the same thing.





       
   
By: Windell (offline) on Monday, April 02 2012 @ 01:28 PM PDT  
Windell

That's not good. If you're getting the same "unable to find..." error on a new system, that may well indicate a hardware error. If you have an extra USB cable of the right type, try swapping that in, just in case. However, I'd recommend at this point that you contact our store directly to request a board swap: http://evilmadscience.com/contact


Windell H. Oskay
drwho(at)evilmadscientist.com
http://www.evilmadscientist.com/

Forum Evil Scientist
Evil Scientist

Status: offline

Registered: 06/15/06
Posts: 1932
Sunnyvale, CA

Profile Email Website  
   
By: Anonymous: esjayel () on Monday, April 02 2012 @ 08:08 PM PDT  
Anonymous: esjayel

Good call on the cable...I switched to a heavier one (with ferrite) and everything just worked. Thanks for the help.





       
   



 All times are PDT. The time is now 06:40 AM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Able to Post 
Filtered HTML Allowed 
Censored Content 

Evil Mad Scientist Forum Archives — Read only!

Please visit our new forums for new discussions.


DIY Hardware for Electronic Art


The Original Egg-Bot Kit


Octolively
Interactive LED kits


Meggy Jr RGB
LED matrix game
development kit.


Business-card sized
AVR target boards


Peggy 2
LED Pegboard kits

My Account






Lost your password?